Skip to end of metadata
Go to start of metadata

[more screenshots under the first image, please scroll down]

HI all,

Let me preface this by saying that I already sent an email to Jon a few days ago reporting this, so he is aware. I would however like to gather a bit more information in order to have a better understanding of the issue and hopefully help him solve it.

Issue #1: on my Samsung Galaxy A51 running Android 10, after opening the Thesarvo app, the main menu hangs on "Checking for updates", which isn’t a normal behaviour. Looks like it isn’t updating normally.

Issue #2: more worrying yet, some crags are missing routes compared to the web version, including major walls.

For example: if you go to Whitewater Wall using a web browser (either on a computer or on a smartphone), it contains different routes from the app version (missing routes 12, as well as 16, 17 and 18). See below:

Left is the app version, right is the web version.

 

There are other things missing on other pages, for example Fruehauf, so I assume a lot of the content isn’t being updated at all.

I don’t remember having this issue on my previous Android phone running Marshmallow.

Has anyone else experienced this or am I alone in this? If yes, please provide as much technical information as you can.

Cheers,
Gabriel

  • No labels

9 Comments

  1. I haven't had time to look at it. Developing on Android pretty much sucks (its just hard work not fun), I don't have an android device, and no one has ever come through to help me on it since the original version was written by Karl then updated by me. Thinking of ditching it - just have web and iOS.

  2. No stress, Jon, it’s really not urgent and I believe you when you say developing on Android is a pain in the ass. I would lend a hand if I knew the first thing about coding, but hopefully this post can get some traction and someone could offer to help.

    Definitely don’t ditch the Android version, it’s still a huge asset to the community and some (most?) users might have no problem at all.

    Thanks and take care.

  3. hey John,

    Is the code up on github? I can try and take a look when I get some spare time (no guarantees on when that will be though).

    cheers

    1. Yes: https://github.com/jonnermut/thesarvo/tree/master/thesarvo-android

      If you get there let me know, its a bit of the process to get the content setup, as it needs separate content packs separate from the app, which is one of the PITA with Andoird

      1. Thanks John,

        It looks like it's using the old APK downloader approach etc. which has all been made obsolete by Google. I think it will need to move to the new model of providing assets, which is actually much simpler than the old model. Anyway, when I get some time, I'll check it out.

        cheers

        1. ok cool, the apk downloader sucks big time, got any details on the new approach?

  4. Cameron McKenzie fixed the issue with the update on Android 10 - thanks a lot for the help. There is a now new version in the Play Store, v1.3.1 with that fix, and updated content.

    1. Great work, just tested it and it works again! All areas and routes up to date, brilliant.